Retailer Email Delay

Incident Report for Headset

Resolved

This incident has been resolved.
Posted Apr 08, 2025 - 10:53 PDT

Identified

Daily summary emails are delayed this morning. Expected to arrive in inboxes by 10:00AM PST.
Posted Apr 08, 2025 - 07:43 PDT