Final Update – May 22, 2025: We’ve completed data remediation for the sales attribution issue affecting Dutchie POS-connected stores. The affected records from May 14 have been corrected, and accurate figures will be reflected on dashboards beginning tomorrow morning.
We appreciate your patience as we worked through this issue. We're continuing to collaborate with Dutchie to reinforce integration reliability and ensure attribution accuracy moving forward.
If you have any questions about your reports or would like confirmation that your store was affected, please reach out to our support team.
Posted May 22, 2025 - 15:10 PDT
Identified
Components Affected: Partner Integrations – Dutchie POS, Sales Reporting Impact Level: Partial Data Inaccuracy Incident Summary: We are currently addressing a data attribution issue affecting a subset of sales reports for retailers connected via our Dutchie POS integration. Specifically, sales transactions from May 14th may have been misattributed to the wrong store locations within our platform, leading to temporarily inflated figures in some reports.
Root Cause: Our investigation indicates that the POS API returned sales data with response formatting that did not always clearly align with the store context associated with each API request. While the data itself was valid, the lack of unambiguous location indicators led to incorrect attribution in downstream reporting.
Current Status and Next Steps: We have isolated the affected data and are finalizing corrections to restore accurate attribution. Updated reports are expected to be available by end of day tomorrow (5/22/2025). In parallel, we’re working with Dutchie to align on response structuring improvements that will help prevent similar issues moving forward.
What You Can Expect:
If your store was impacted, corrected reports will be automatically applied
No action is required on your end
You will be notified once updates are fully complete
We appreciate your patience as we resolve this matter. Our goal is to ensure data quality and transparency while continuing to strengthen our integration with key partners like Dutchie.
Posted May 21, 2025 - 17:24 PDT
This incident affected: Data Pipeline (POS Integrations).